jbuilder

AuthorJane Street Group, LLC <opensource@janestreet.com>
LicenseApache-2.0
Homepagehttps://github.com/janestreet/jbuilder
Issue Trackerhttps://github.com/janestreet/jbuilder/issues
Maintaineropensource@janestreet.com
Dependencies
ocamlfind
Availableocaml-version >= "4.02.3"
PublishedMar 22, 2017
Source [http] https://github.com/janestreet/jbuilder/archive/1.0+beta5.tar.gz
609a647290e42d1f7af7fcad24b6ce08
StatisticsNot installed in the last month.
Edithttps://github.com/ocaml/opam-repository/tree/master/packages/jbuilder/jbuilder.1.0+beta5/opam

Fast, portable and opinionated build system

jbuilder is a build system that was designed to simplify the release of Jane Street packages. It reads metadata from "jbuild" files following a very simple s-expression syntax.

jbuilder is fast, it has very low-overhead and support parallel builds on all platforms. It has no system dependencies, all you need to build jbuilder and packages using jbuilder is OCaml. You don't need or make or bash as long as the packages themselves don't use bash explicitely.

jbuilder supports multi-package development by simply dropping multiple repositories into the same directory.

It also supports multi-context builds, such as building against several opam roots/switches simultaneously. This helps maintaining packages across several versions of OCaml and gives cross-compilation for free.

Necessary for
acgtk
>= 1.3.2
amqp-client
>= 1.1.0
ANSITerminal
>= 0.8
ascii85
>= 0.4
async_js
&>= v0.9.1
v0.10.0
async_parallel
&>= v0.9.1
v0.10.0
async_shell
&>= v0.9.1
v0.10.0
async_unix
&>= v0.9.1
v0.10.0
atdgen
>= 1.10.2
aws-s3
>= 1.1.0
base
v0.9.2
bin_prot
&>= v0.9.0
v0.9.1
biniou
&>= 1.1.0
1.2.0
bitmasks
>= 1.1.0
bitstring
>= 3.0.0
brotli
>= 2.0.3
bst
build_path_prefix_map
capnp
>= 3.0.0
caqti
caqti-async
caqti-driver-mariadb
caqti-driver-postgresql
caqti-driver-sqlite3
caqti-dynload
caqti-lwt
caqti-type-calendar
cfstream
>= 1.2.3
clarity
>= 0.3.1
cmdtui
>= 0.4.3
cmdtui-lambda-term
core
&>= v0.9.1
v0.10.0
core_extended
&>= v0.9.1
v0.10.0
core_kernel
&>= v0.9.1
v0.10.0
cowabloga
>= 0.3.0
crowbar
csv-lwt
csvfields
&>= v0.9.1
v0.10.0
datakit
&>= 0.10.0
0.12.0
datakit-bridge-github
&>= 0.10.0
0.12.0
datakit-bridge-local-git
&>= 0.10.0
0.12.0
datakit-ci
&>= 0.10.0
0.12.0
datakit-client
&>= 0.10.0
0.12.0
datakit-client-9p
0.12.0
datakit-client-git
0.12.0
datakit-github
&>= 0.10.0
0.12.0
datakit-server
&>= 0.10.0
0.12.0
datakit-server-9p
0.12.0
doc-ock
>= 1.1.0
doc-ock-html
>= 1.1.0
doc-ock-xml
>= 1.1.0
DrawGrammar
>= 0.2.1
dryunit
dune_watch
easy-format
>= 1.3.0
email_message
&>= v0.9.1
v0.10.0
exenum
>= 0.82.0
fftw3
>= 0.8
fieldslib
&>= v0.9.0
v0.10.0
gapi-ocaml
>= 0.3.6
gdbprofiler
>= 0.2
gen
>= 0.5.1
General
>= 0.4.0
git
>= 1.11.0
git-http
>= 1.11.0
git-mirage
>= 1.11.0
git-unix
>= 1.11.1
gnuplot
>= 0.5.3
google-drive-ocamlfuse
>= 0.6.23
graphql
graphql-async
graphql-lwt
graphql_parser
hashids
irmin
&>= 1.2.0
1.3.0
irmin-fs
1.3.0
irmin-git
&>= 1.2.0
1.3.0
irmin-http
&>= 1.2.0
1.3.0
irmin-mem
1.3.0
irmin-mirage
&>= 1.2.0
1.3.0
irmin-unix
&>= 1.2.0
1.3.0
JsOfOCairo
>= 1.0.1
jupyter-kernel
kafka
>= 0.3
kicadsch
kyotocabinet
levenshtein
>= 1.1.3
libsvm
>= 0.9.4
links
>= 0.7.2
links-postgresql
lwt_camlp4
lwt_log
malfunction
mccs
1.1+3
mesh-display
mesh-graphics
minimal
mirage-block-unix
&>= 2.8.2
2.8.3
mirage-nat
mirage-net-flow
mirage-net-macosx
>= 1.4.0
moss
mustache
>= 3.0.2
mvar
nonstd
>= 0.0.3
npy
>= 0.0.5
nsq
numalib
oc45
ocaml-compiler-libs
v0.10.0
ocaml-migrate-parsetree
1.0
ocaml-top
>= 1.1.4
ocamlformat
odoc
&>= 1.1.0
1.2.0
opam-package-upgrade
opium
>= 0.16.0
opium_kernel
optimization1d
>= 0.6
orandforest
orec
osbx
otetris
owl
>= 0.3.0
parsexp
&>= v0.9.1
v0.10.0
parsexp_io
&>= v0.9.1
v0.10.0
pla
>= 1.2
plotkicadsch
posixat
&>= v0.9.1
v0.10.0
ppx_assert
&>= v0.9.0
v0.10.0
ppx_ast
v0.10.0
ppx_base
v0.10.0
ppx_bench
&>= v0.9.0
v0.9.1
ppx_bin_prot
&>= v0.9.0
v0.10.0
ppx_bitstring
>= 2.0.0
ppx_blob
>= 0.3.0
ppx_compare
&>= v0.9.0
v0.10.0
ppx_conv_func
&>= v0.9.0
v0.10.0
ppx_core
&>= v0.9.0
v0.9.3
ppx_custom_printf
&>= v0.9.0
v0.10.0
ppx_deriving_protocol
0.8.1
ppx_driver
&>= v0.9.0
v0.9.1
ppx_dryunit
ppx_enumerate
&>= v0.9.0
v0.10.0
ppx_expect
&>= v0.9.0
v0.10.0
ppx_fail
&>= v0.9.0
v0.10.0
ppx_fields_conv
&>= v0.9.0
v0.10.0
ppx_graphql
ppx_hardcaml
>= 1.3.0
ppx_hash
v0.10.0
ppx_here
&>= v0.9.0
v0.9.1
ppx_inline_test
&>= v0.9.0
v0.9.1
ppx_jane
&>= v0.9.0
v0.10.0
ppx_js_style
v0.10.0
ppx_let
&>= v0.9.0
v0.10.0
ppx_meta_conv
>= 4.0.0
ppx_metaquot
v0.10.0
ppx_monadic
>= 2.3.0
ppx_nanocaml
ppx_optcomp
&>= v0.9.0
v0.10.0
ppx_optional
v0.10.0
ppx_orakuda
>= 3.3.0
ppx_pipebang
&>= v0.9.0
v0.10.0
ppx_poly_record
>= 1.3.0
ppx_protocol_conv
ppx_regexp
ppx_sexp_conv
&>= v0.9.0
v0.10.0
ppx_sexp_message
&>= v0.9.0
v0.10.0
ppx_sexp_value
&>= v0.9.0
v0.10.0
ppx_test
>= 1.6.0
ppx_traverse
v0.10.0
ppx_traverse_builtins
v0.10.0
ppx_type_conv
&>= v0.9.0
v0.9.1
ppx_typerep_conv
&>= v0.9.0
v0.10.0
ppx_variants_conv
&>= v0.9.0
v0.10.0
ppxx
>= 2.3.1
prometheus
&>= 0.2
0.3
prometheus-app
&>= 0.2
0.3
protocol-9p
&>= 0.10.0
0.11.0
protocol-9p-tool
0.11.2
protocol-9p-unix
0.11.0
qcheck
>= 0.8
qcow
&>= 0.10.0
0.10.3
qcow-tool
reason
>= 3.0.3
redis
>= 0.3.4
redis-lwt
redis-sync
sexplib
&>= v0.9.0
v0.9.2
spacetime_lib
>= 0.2.0
sphinxcontrib-ocaml
>= 0.3.0
spotlib
>= 4.0.3
sslconf
stdio
v0.10.0
tar
0.9.0
tar-mirage
0.9.0
telegraml
>= 2.2.0
tensorflow
>= 0.0.10
tiny_json
>= 1.1.5
traildb
travis-opam
>= 1.2.0
trax
treeprint
>= 2.2.0
tube
4.1
typerep
&>= v0.9.0
v0.10.0
typpx
>= 1.4.3
unmagic
>= 1.0.4
variantslib
&>= v0.9.0
v0.10.0
vcardgen
>= 1.1
vhd-format
>= 0.9.1
vhd-format-lwt
virtual_dom
&>= v0.9.1
v0.10.0
wcs-lib
yojson
>= 1.4.0