why3

Maintainerhttps://github.com/ocaml/opam-repository/issues
Dependencies
&alt-ergo
coq8.3
ocamlgraph1.8.2
sqlite3
Optional dependencies
lablgtk
Availableocaml-version < "4.06.0"
PublishedMar 22, 2013
Source [http] https://gforge.inria.fr/frs/download.php/31724/why3-0.80.tar.gz
4b50adf812a34879be92f27f25be7ec9
StatisticsNot installed in the last month.
Edithttps://github.com/ocaml/opam-repository/tree/master/packages/why3/why3.0.80/opam

Next generation of the Why software verification platform

Why3 clearly separates the purely logical specification part from generation of verification conditions for programs. It features a rich library of proof task transformations that can be chained to produce a suitable input for a large set of theorem provers, including SMT solvers, TPTP provers, as well as interactive proof assistants.