ppx_deriving

MaintainerPeter Zotov <whitequark@whitequark.org>
Dependencies
&ocamlbuild
ocamlfind
ppx_tools>= 0.99
OCaml>= 4.02.0 & < 4.03
PublishedJul 29, 2014
Source [http] https://github.com/whitequark/ppx_deriving/archive/v0.2.tar.gz
c36bfc351b67f42793b849a6d18ea2e8
StatisticsInstalled 5 times last month.
Edithttps://github.com/ocaml/opam-repository/tree/master/packages/ppx_deriving/ppx_deriving.0.2/opam

Type-driven code generation for OCaml >=4.02

Necessary for
amf
ansi-parse
async-zmq
>= 0.3.0
biocaml
&>= 0.4.0
0.7.0
bistro
&>= 0.2.0
0.3.0
bookaml
>= 3.1
boomerang
bpf
bulletml
camlhighlight
>= 4.0
charrua-core
&>= 0.3
0.6
coclobas
cohttp
&>= 0.20.1
0.99.0
conduit
&>= 0.15.4
1.0.0
datakit-ci
0.10.0
dns
&>= 0.19.1
0.20.0
dockerfile
&>= 1.3.0
3.0.0
electrod
0.1.6
eliom
>= 6.0.0
elpi
fstar
>= 0.9.6.0~alpha1
goblint
ibx
>= 0.8.1
jhupllib
0.1.1
js_of_ocaml-ppx_deriving_json
ketrew
|2.0.0
>= 3.0.0
kinetic-client
>= 0.0.9
kremlin
m17n
mirage-net-xen
&>= 1.6.0
1.7.1
msgpck
1.1
multipart-form-data
0.2.0
nbd
>= 2.1.0
netml
nocrypto
>= 0.5.3
ocaml-topexpect
ocamllint
0.2.0
oci
opass
>= 1.0.6
opium
&>= 0.15.0
0.16.0
otr
>= 0.3.1
passmaker
perf
planck
>= 2.2.0
ppx_assert
113.24.00
ppx_bench
113.24.00
ppx_bin_prot
113.24.00
ppx_compare
113.24.00
ppx_conv_func
113.24.00
ppx_core
113.24.00
ppx_csv_conv
113.24.00
ppx_custom_printf
113.24.00
ppx_deriving_yojson
2.0
ppx_driver
113.24.00
ppx_enumerate
113.24.00
ppx_fail
113.24.00
ppx_fields_conv
113.24.00
ppx_here
113.24.00
ppx_implicits
>= 0.2.0
ppx_inline_test
113.24.00
ppx_jsobject_conv
0.5.0
ppx_netblob
>= 1.2.1
ppx_optcomp
113.24.00
ppx_pipebang
113.24.00
ppx_sexp_conv
113.24.00
ppx_sexp_value
113.24.00
ppx_typerep_conv
113.24.00
ppx_variants_conv
113.24.00
ppx_xml_conv
113.24.00
protocol-9p
&>= 0.6.0
0.12.0
protocol-9p-unix
0.12.0
qcow
0.10.0
qcow-format
>= 0.3
rpc
>= 1.9.51
shared-block-ring
>= 2.3.0
snabela
sparrow
0.2
sqlgg
>= 0.4.4
tls
>= 0.7.1
transmission-rpc
unmagic
1.0.4
uri
&>= 1.9.2
1.9.4
vchan
&>= 2.1.0
3.0.0
vmnet
&>= 1.1.0
1.2.0
wamp
1.1
x509
&>= 0.5.1
0.6.0
Optional for
cconv
>= 0.3
js_of_ocaml
&>= 2.7
3.0
js_of_ocaml-ppx
3.1.0
lens
>= 1.1.0
libsvm
&>= 0.9.3
0.9.4
ppx_type_conv
&>= v0.9.0
v0.9.1