tube

AuthorAlin Popa
LicenseLGPL-3 with OCaml linking exception
Homepagehttps://github.com/alinpopa/tube
Issue Trackerhttps://github.com/alinpopa/tube/issues
Maintaineralin.popa@gmail.com
Dependencies
&dune>= 1.0
lwt
Availableocaml-version >= "4.04.0"
PublishedJul 11, 2018
Source [http] https://github.com/alinpopa/tube/archive/4.4.0.tar.gz
65e17606d445d517aad1f912daca4d88
StatisticsInstalled 2 times last month.
Edithttps://github.com/ocaml/opam-repository/tree/master/packages/tube/tube.4.4.0/opam

Typesafe abstraction on top of Lwt_io channels

A typesafe abstraction on top of Lwt_io channels in order to avoid things like unsafe operations (i.e. https://github.com/ocsigen/lwt/issues/345 ) when running in practice.

No package is dependent