protocol_version_header

AuthorJane Street Group, LLC <opensource@janestreet.com>
LicenseApache-2.0
Homepagehttps://github.com/janestreet/protocol_version_header
Issue Trackerhttps://github.com/janestreet/protocol_version_header/issues
Maintaineropensource@janestreet.com
Dependencies
&core_kernel>= v0.11&v0.12
jbuilder>= 1.0+beta18.1
ocaml-migrate-parsetree>= 1.0
ppx_jane>= v0.11&v0.12
Availableocaml-version >= "4.04.1"
PublishedMar 20, 2018
Source [http] https://ocaml.janestreet.com/ocaml-core/v0.11/files/protocol_version_header-v0.11.0.tar.gz
a188d7194a0f5c6d65cfdc5eba8d797b
StatisticsInstalled 534 times last month.
Edithttps://github.com/ocaml/opam-repository/tree/master/packages/protocol_version_header/protocol_version_header.v0.11.0/opam

Protocol versioning

This library offers a lightweight way for applications protocols to version themselves. The more protocols that add themselves to [Known_protocol], the nicer error messages we will get when connecting to a service while using the wrong protocol.

Necessary for
async_rpc_kernel
>= v0.11.0