ocaml-migrate-parsetree

AuthorsFrédéric Bour <frederic.bour@lakaban.net> and Jérémie Dimino <jeremie@dimino.org>
LicenseLGPL-2.1
Homepagehttps://github.com/let-def/ocaml-migrate-parsetree
Issue Trackerhttps://github.com/let-def/ocaml-migrate-parsetree/issues
Tagssyntax and org:ocamllabs
Maintainerfrederic.bour@lakaban.net
Dependencies
&jbuilder>= 1.0+beta2
ocamlfind
result
Availableocaml-version >= "4.02.0" & ocaml-version < "4.06.0"
PublishedMar 21, 2017
Source [http] https://github.com/let-def/ocaml-migrate-parsetree/archive/v0.6.tar.gz
f615fe49e82202ba9e93a42ef5bba17a
StatisticsNot installed in the last month.
Edithttps://github.com/ocaml/opam-repository/tree/master/packages/ocaml-migrate-parsetree/ocaml-migrate-parsetree.0.6/opam

Convert OCaml parsetrees between different versions

This library converts parsetrees, outcometree and ast mappers between different OCaml versions. High-level functions help making PPX rewriters independent of a compiler version.

Necessary for
async
&>= v0.9.0
v0.11.0
async_durable
v0.11.0
async_extended
&>= v0.9.0
v0.11.0
async_extra
&>= v0.9.0
v0.11.0
async_find
&>= v0.9.0
v0.11.0
async_inotify
&>= v0.9.0
v0.11.0
async_interactive
v0.11.0
async_js
v0.11.0
async_kernel
&>= v0.9.0
v0.11.0
async_parallel
&>= v0.9.0
v0.11.0
async_rpc_kernel
&>= v0.9.0
v0.11.0
async_sendfile
v0.11.0
async_shell
&>= v0.9.0
v0.11.0
async_smtp
&>= v0.9.0
v0.11.0
async_ssl
&>= v0.9.0
v0.11.0
async_unix
&>= v0.9.0
v0.11.0
bignum
&>= v0.9.0
v0.11.0
bin_prot
&>= v0.9.0
v0.11.0
command_rpc
v0.11.0
configurator
v0.10.0
core
&>= v0.9.0
v0.11.0
core_bench
&>= v0.9.0
v0.11.0
core_extended
&>= v0.9.0
v0.11.0
core_kernel
&>= v0.9.0
v0.11.0
core_profiler
&>= v0.9.0
v0.11.0
cstruct
&>= 2.4.1
3.0.0
csvfields
v0.11.0
delimited_parsing
v0.11.0
ecaml
v0.11.0
elpi
email_message
&>= v0.9.0
v0.11.0
expect_test_helpers
v0.11.0
expect_test_helpers_kernel
v0.11.0
fieldslib
&>= v0.9.0
v0.11.0
fstar
>= 0.9.6.0
graphql_ppx
incr_dom
v0.11.0
incr_dom_widgets
v0.11.0
incr_map
v0.11.0
incr_select
v0.11.0
incremental
&>= v0.9.0
v0.11.0
incremental_kernel
&>= v0.9.0
v0.11.0
jane-street-tests
jenga
&>= v0.9.0
v0.11.0
js_of_ocaml
>= 3.0
js_of_ocaml-ppx
json-wheel_jane_street_overlay
lablqml
&>= 0.5.1
0.6
line-up-words
v0.11.0
lwt
&>= 3.1.0
4.0.0
lwt_ppx
mecab
mlt_parser
v0.11.0
multipart-form-data
>= 0.2.0
nsq
>= 0.2.4
ocaml-migrate-parsetree-ocamlbuild
ocaml-monadic
>= 0.4.0
ocaml_plugin
&>= v0.9.0
v0.11.0
omonad
>= 0.3.3
parsexp
v0.11.0
parsexp_io
v0.11.0
patdiff
&>= v0.9.0
v0.11.0
patience_diff
&>= v0.9.0
v0.11.0
pla
>= 1.2
posixat
&>= v0.10.0
v0.11.0
ppx_assert
&>= v0.9.0
v0.11.0
ppx_ast
|v0.9.2
&>= v0.10.0
v0.11.0
ppx_base
v0.11.0
ppx_bench
&>= v0.9.0
v0.11.0
ppx_bin_prot
&>= v0.9.0
v0.11.0
ppx_bitstring
&>= 2.0.0
2.0.2
ppx_blob
>= 0.3.0
ppx_compare
&>= v0.9.0
v0.11.0
ppx_compose
ppx_conv_func
&>= v0.9.0
v0.11.0
ppx_cstruct
>= 3.0.1
ppx_csv_conv
&>= v0.9.0
v0.11.0
ppx_custom_printf
&>= v0.9.0
v0.11.0
ppx_defer
>= 0.3.0
ppx_deriving
>= 4.2
ppx_deriving_argparse
ppx_driver
&>= v0.9.0
v0.9.1
ppx_dryunit
ppx_enumerate
&>= v0.9.0
v0.11.0
ppx_expect
&>= v0.9.0
v0.11.0
ppx_fail
&>= v0.9.0
v0.11.0
ppx_fields_conv
&>= v0.9.0
v0.11.0
ppx_gen_rec
ppx_hash
v0.11.0
ppx_here
&>= v0.9.0
v0.11.0
ppx_implicits
>= 0.2.0
ppx_inline_test
&>= v0.9.0
v0.11.0
ppx_jane
&>= v0.9.0
v0.11.0
ppx_js_style
v0.11.0
ppx_jsobject_conv
>= 0.5.0
ppx_let
&>= v0.9.0
v0.11.0
ppx_metaquot
v0.11.0
ppx_nanocaml
ppx_optional
v0.11.0
ppx_pipebang
&>= v0.9.0
v0.11.0
ppx_regexp
ppx_sexp_conv
&>= v0.9.0
v0.11.0
ppx_sexp_message
&>= v0.9.0
v0.11.0
ppx_sexp_value
&>= v0.9.0
v0.11.0
ppx_sqlexpr
ppx_tools_versioned
|5.0.1
>= 5.2
ppx_traverse
v0.11.0
ppx_type_conv
&>= v0.9.0
v0.11.0
ppx_typerep_conv
&>= v0.9.0
v0.11.0
ppx_variants_conv
&>= v0.9.0
v0.11.0
ppx_view
ppx_xml_conv
&>= v0.9.0
v0.11.0
ppxfind
ppxx
>= 2.0.0
prettiest
protocol_version_header
v0.11.0
pumping
re2
&>= v0.9.0
v0.11.0
reason
>= 1.11.0
reason-parser
record_builder
v0.11.0
rpc_parallel
&>= v0.9.0
v0.11.0
sedlex
>= 1.99.4
sexp_pretty
v0.11.0
splay_tree
v0.11.0
textutils
&>= v0.9.0
v0.11.0
textutils_kernel
v0.11.0
toplevel_expect_test
&>= v0.10.0
v0.11.0
topological_sort
v0.11.0
typerep_extended
>= v0.9.0
variantslib
&>= v0.9.0
v0.11.0
virtual_dom
v0.11.0
vmnet
>= 1.3.0
wcs-lib
>= 2017-05-26.02
yara