gapi-ocaml

Author Alessandro Strada
License MIT
Homepage http://gapi-ocaml.forge.ocamlcore.org
Issue Tracker https://github.com/astrada/gapi-ocaml/issues
Maintainer Alessandro Strada <alessandro.strada@gmail.com>
Dependencies
& cryptokit
ocamlfind
ocamlnet
ocurl
xmlm
yojson
| extlib
extlib-compat
Optional dependencies
| ounit
pa_monad_custom
Available ocaml-version >= "3.12.0"
Published Dec 7, 2015
Source [http] http://forge.ocamlcore.org/frs/download.php/1581/gapi-ocaml-0.2.7.tar.gz
54d49c6675488b63aae72e4ba9fc67ca
Statistics Installed 2 times in last month.
Edit https://github.com/ocaml/opam-repository/tree/master/packages/gapi-ocaml/gapi-ocaml.0.2.7/opam

A simple OCaml client for Google Services.

gapi-ocaml is a simple, unofficial, OCaml client for Google Services. The library supports ClientLogin, OAuth 1.0a, and OAuth 2.0 authentication. Supported RESTful APIs: Calendar APIs v3, Google+ API v1, Tasks API v1, APIs Discovery Service v1, URL Shortener API v1, OAuth2 API v2, Custom Search API v1, Google Analytics API v3, Page Speed Online API v1, Blogger API v2, Site Verification API v1, AdSense Management API v1.4, BigQuery API v2, Drive API v2, Gmail API v1. Google Data Protocol APIs (GData): Google Documents List API v3.

Necessary for
google-drive-ocamlfuse
& >= 0.5.6
0.5.21